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General Safety Summary

General Safety Summary

Review the following safety precautions carefully before operate the device to avoid any
personal injuries or damages to the device and any products connected to it. To avoid
potential hazards use the device as specified by this user’s guide only.

*

*

To Avoid Fire or Personal Injury

Use Proper Power Cord. Use only the power cord specified for this product and
certified for the country of use.

Connect and Disconnect Properly. Do not connect or disconnect probes or test
leads while they are connected to a voltage source.

Connect and Disconnect Properly. Connect the probe output to the measurement
device before connecting the probe to the circuit under test. Disconnect the probe input
and the probe reference lead from the circuit under test before disconnecting the probe
from the measurement device.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings
and markings on the product. Consult the product manual for further ratings information
before making connections to the product.

Use Proper Probe. To avoid shock hazard, use a properly rated probe for your
measurement.

Avoid Circuit or Wire Exposure. Do not touch exposed connections and components
when power is on.

Do Not Operate With Suspected Failures. If suspected damage occurs with the
device, have it inspected by qualified service personnel before further operations.

Provide Proper Ventilation. Refer to the installation instructions for proper ventilation of
the device.

Do not operate in Wet/Damp Conditions.
Do not operate in an Explosive Atmosphere.

Keep Product Surfaces Clean and Dry.
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General Safety Summary

Safety Information
In order to ensure the correct using and the best efficient service, please carefully read the
user's manual.

System Symbols
These symbols may appear in this manual or on the instrument.

Warning: “Waring” identifies conditions and actions that pose hazards to the
users.

Caution: “Caution” identifies conditions and actions that may damage the
product or other properties.

A A D 7 =

DANGER: Refer to Protective Chassis grand Earth(grand)

High Voltage the manual Condutor Terminal Terminal

System Terms

The following terms may appear on the instrument:

Danger: The term “Danger” is used in the manual to indicate that when you read this mark,
personal injury may be caused to immediately.

Waning: The term “Danger” is used in the manual to indicate that when you read this mark,
personal injury may not be caused to you immediately, but you need to be cautionary.

Notice: The term “Noise” is used in this manual to indicate that damages may be caused on
this product or other properties.
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Chapter 1 Getting Start

Chapter 1 Getting Start

The oscilloscope is small, lightweight, no external power required, portable oscilloscopes. The
oscilloscopes is ideal for production test, research and design and all of the applications

involving analog circuits test and troubleshooting, as well as education and training.

In addition to the list of general features on the next page, this chapter describes how to do the

following tasks:

€4 System Requirements
Install Software
Install Driver

General Check

Self Calibration

*

*

L 4

¢ Probe Compensation
¢

€ Function Check

*

Accessories
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Chapter 1 Getting Start

1.1 System Requirement

To run the oscilloscope software, the needs of computer configuration are as follows:
Minimum System Requirements

Operating System
Windows XP/Vista/Win 7/Win 8

Processor

Upwards of 1.00G processor

Memory
256M byte

Disk Space
500M disk free space

Screen resolution
800 x 600

Recommended Configuration

Operating System
Windows XP SP3 System

Processor

2.4G Processor

Memory
1G Byte Memory

Disk Space
80G Disk Space

Screen resolution
1024 x 768 or 1280 x 1024 resolution

DPI Setting
Normal Size (96DPI)
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Chapter 1 Getting Start

1.2 Install Software

Caution: You must install the software before using the oscilloscope.
Example: Hantek6212BE
1. While in Windows, insert the installation CD into the CD-ROM drive.

2. The installation should start up automatically. Otherwise in Windows Explorer, switch to
the CD-ROM drive and run Setup.exe.

Hantek6212BE [Verl_0.0.1] Installation

Initializing Wise Inzstallation Wizard. .

3. The software Installation is started. Click 'Next' to continue.

43 Hant ek6212BE (Verl. 0. 0. 1)

YWelcome to HantekB212BE [Werl .0.0.1] Setup program. This
program will install Hantek 621 2BE [Werl.0.0.1] on wour computer.

[t iz gtrongly recommended that you exit all Windows programs
befare running thiz Setup Program.

Click Cancel to guit Setup and close any programs you have
runhing. Click Mext to cantinue with the Setup pragran.

WARMIMG: Thiz program iz protected by copuright law and
international treaties.

IInauthonzed reproduction or distnibution of thiz program, or any
portian of it, may result in zevere civil and criminal penalties, and
will be progecuted to the maximum extent pozsible under law,
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Chapter 1 Getting Start

4. Choose a destination directory. Click 'Next' to continue.

42 Hantek6212BE (Verl. 0. 0. 1)

Destination Location

Setup will install Hantek B21 2BE[Wer1.0.0.1] in the following folder.
To install into a different folder, click Browse, and select anather folder.

Y'ou can chooge not to install Hantek 621 2BE Merl . 0.0.1] by clicking Cancel to exit Setup.

Dreztination Falder

D-\Pragram Files\Hantek521 2BE

ize |Inztallation ‘Wizard?

< Back Cancel

5. Check the setup information. Click Next to start copying of files.

42 Hant ek6212BE (Verl. 0. 0. 1)

Start Installation

Y'ou are how ready toingtall Hantek 621 2BE [VMerl .0.0.1].

Click the Mest button to begin the inztallation or the Back button to reenter the installation
inforrnatiorn,

ize Inztallation Wizard?

< Back Caricel
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Chapter 1 Getting Start

6. This Status dialog is displayed during copying of files.

HantekfZ212BE (¥erl. 0. 0. 1)

Installing

— Current File

I:l:ll:l_lr“rlg fllE.

[:5Program FilesH antelk621 2BE \DrivertHantekB21 2BE=862. sus

— Al Files

Time Bemaining 0 minutes 2 seconds

ize Inztallation YWizard?

< Back et >

7. Updating Your System Configuration.

@ |Ipdating System Configuration, Please Wwait...
=

8. The installation is complete.

43 Hantek6212BE (Verl. 0. 0. 1)

HantekB212BENer! .0.0.1] has been successfully installed.

Click the Finizh button to exit thiz inztallation.

< Back

Canizel |
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Chapter 1 Getting Start

1.3 Install Driver

1. Connect the A-Type Plug of USB cable to your PC’s USB port.

2. Connect the B-Type Plug of USB cable to Hantek6212BE’s USB port.

3. New hardware is found.

i) Found New Hardware
Hantek xco: DERTWVER 1

4. New hardware search wizard starts.

Found Mew Hardware Wizard

Thiz wizard helps vou inztall software far;
Hantek woo DRIVER 1

.i';i If your hardware came with an installation CD
2= or floppy disk, insert it now.

YWhat do you want the wizard to do’?

{7 Install the software automatically [Fecommended]

&ilnztall from a list or gpecific location [Advanced}

Click Mest o continue.

< Back ” MNewt » l[ Cancel
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Chapter 1 Getting Start

5. New hardware search wizard starts to search the drive.

Found New Hardware Wizard

Please choose your search and installation options.

(%) Search for the best driver in these locations.

I1ze the check bowes below ta limit or expand the default zearch, which includes local
pathz and removable media. The best driver found will be installed.

[ ] 5earch removable media (floppy, CO-ROM...|

[nizlude this lozation in the search:

n::urner‘ut:z: and SettingzYadministratorDeskiophDrive v| [ Browse

() Don't zearch. | will choose the driver to install

Chonoze this option ta select the device driver from a list. Windows does not guarantes that
the driver you chooze will be the best match for vour hardware.

< Back ” MHest » ][ Cancel

6. New hardware wizard installs software

Found Mew Hardware Wizard

Please wait while the wizard searches. .

et s Cancel

7. Finish new hardware search wizard.
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Chapter 1 Getting Start

Found Mew Hardware Wizard

Completing the Found New
Hardware Wizard

The wizard has finished inztaling the zoftware for:

ﬂ.ﬁ] Hantek wooo DERTVER 1

Click Finizh to cloze the wizard.

8. New hardware is found.
=

le Found Mew Hardware
Hantek oo DERIWER 2

9. Found new hardware Wizard. Select “Install the software automatically”.

Found Mew Hardware Wizard

Thiz wizard helpz you install softvare for;
Hantek wooe DRIVER. 2

':]l If your hardware came with an installation CD
= or floppy disk. insert it now.

YWhat da you want the wizard to da?

(%) Install the software automatically [Recommended)

ilnstall from a list or specific location [Advanced)

Click Mest to continue,

< Back ” Met » l[ Cancel
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Chapter 1 Getting Start

10. New hardware wizard installs software and finish new hardware search wizard.

Found Mew Hardware Wizard

Completing the Found New
Hardware Wizard

The wizard haz finished inztalling the software for:

[ﬁ] Hantek wcoo DERTVER 2

Click, Finizh to cloze the wizard,

11. Your new hardware is installed and ready to use.

i) Found New Hardware

our new hardware is installed and ready to use.

Hantek6102BE/Hantek6212BE User’s Manual
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Chapter 1 Getting Start

1.4 General Check

Please check the instrument as following steps after receiving an oscilloscope:

Check the shipping container for damage:

Keep the damaged shipping container or cushioning material until the contents of the
shipment have been checked for completeness and the instrument has been checked
mechanically and electrically.

Check the accessories:
Accessories supplied with the instrument are listed in "Accessories" in this guide. If the
contents are incomplete or damaged, please notify the franchiser.

Check the instrument:
In case there is any mechanical damage or defect, or the instrument does not operate
properly or fails performance tests, please notify the franchiser.

1.5 Probe Compensation

Perform this function to match the characteristics of the probe and the channel input. This
should be performed whenever attaching a probe to any input channel at the first time.

€ From the “Probe” menu, select attenuation to 1:10. Set the switch to “X10” on the probe
and connect it to CH1 of the oscilloscope. When using the probe hook-tip, insert the tip onto
the probe firmly to ensure a proper connection.

€ Attach the probe tip to the Probe Compensator and the reference lead to the ground
connector, select CH1, and then press the “AUTOSET” button into the menu or the toolbar.

€ Check the shape of the displayed waveform.

Correctly Compensated

Hantek6102BE/Hantek6212BE User’s Manual 12



Chapter 1 Getting Start

Over compensated

Under Compensated
€ If necessary, use a non-metallic tool to adjust the trimmer capacitor of the probe for

the fattest square wave being displayed on the oscilloscope.

€ Repeat if necessary.

WARNNING: To avoid electric shock while using the probe, be sure the perfection of the
insulated cable, and do not touch the metallic portions of the probe head while it is connected
with a voltage source.

1.6 Self Calibration

The self calibration routine lets you optimize the oscilloscope signal path for maximum
measurement accuracy. You can run the routine at any time but you should always run the
routine if the ambient temperature changes by 5v or more. For accurate calibration, power on
the oscilloscope and wait twenty minutes to ensure it is warmed up. To compensate the
signal path, disconnect any probes or cables from the input connectors. Then, access the
“Utility -> Calibration” option and follow the directions on the screen. The self calibration
routine takes about several minutes.
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Chapter 1 Getting Start

1.7 Function Check

Perform this functional check to verify that your oscilloscope is operating correctly.

€4 Connect the oscilloscope
You should connect the A-Type Plug of USB cable to your PC USB port and connect the

B-Type Plug of USB cable to oscilloscope USB port.

€ Input a signal to a channel of the oscilloscope
The oscilloscope is equipped with two channels plus external trigger.

Please input signal in the following steps:

1. Set the attenuation switch on the probe as 10X and connect the probe on the oscilloscope
with CH1. Aim the slot in the probe connector at the faucet on BNC of CH1 and insert, then,
turn right to lock the probe. Finally, attach the tip of probe and ground nip to the Connector of

Probe compensator.

Hantek6102BE/Hantek6212BE User’s Manual 14



Chapter 1 Getting Start

3. Attach the tip of probe and ground nip to the Connector of Probe compensator. Click the

AU
TO  putton. A square wave will be displayed within a several seconds. (Approximately 1

kHz, 2V, peak- to- peak).

4. Inspect CH2 with the same method. Repeat steps 2 and 3.

1.8 Accessories

All the accessories listed below are standard accessories for the oscilloscope:
€ Probe x 2 (1.5m), 1:1, (10:1) Passive Probes
4 A USB Cable

€ A PC software of the oscilloscope

Hantek6102BE/Hantek6212BE User’s Manual 15
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Chapter 2 Operating Basics

The User’s Interface
The Menu System

The Horizontal System
The Vertical System

The Trigger System

*® & ¢ O o o

Input Connectors

Hantek6102BE/Hantek6212BE User’s Manual
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Chapter 2 Operation Basic

2.1 The User’s Interface

Click the software icon on the desk after you finished the software setting and equipment
connecting. Then a user interface will be showed as follows:

" Hantel X200 BE ( V1.0.0)

1. The Main Menu
All setting can be found in the main menu.
2. The Toolbar
3. Displays the trigger information
Displays the edge trigger slope, source and level.
4. The Horizontal Panel
The user can change Time/Div, format in the panel.
5. The vertical Panel
The user can turn on/off the CH1/CH2.Also the user can change the CH1/CH2 volt/div,
coupling and probe attenuation.
6. The Trigger Panel
In this panel, the user can change the trigger mode, sweep, source and slope.
7. Displays the system time.
8. Displays the main time base setting.
9. Marker shows Edge trigger level.

10. Displays the CH2 information

Hantek6102BE/Hantek6212BE User’s Manual 17



Chapter 2 Operation Basic

Readout show the coupling of the channels.
Readout show the vertical scale factors of the channels.
A “B” icon indicates that the channel is bandwidth.
11. Displays the CH1 information
Readout show the coupling of the channels.
Readout show the vertical scale factors of the channels.
A “B” icon indicates that the channel is bandwidth.
12. The marker shows the reference points of the displayed waveforms.
If there is no marker, the channel is not displayed.
13. The same as 13.
14. A window that shows the display waveform in buffer position.
15. Marker shows horizontal trigger position.
16. Trigger status indicates the following.
Auto: The oscilloscope is in auto mode and is acquiring waveform waveform in the absence
of triggers.
Trig’D: The oscilloscope has seen a trigger and is acquiring the post trigger data.
WAIT: All pretrigger data has been acquired and the oscilloscope is ready to accept a
trigger.
Stop: The oscilloscope has stopped acquiring waveform data.
Run: The oscilloscope is running.

Play: The oscilloscope is displaying the record waveform.

Hantek6102BE/Hantek6212BE User’s Manual 18



Chapter 2 Operation Basic

2.2 The Menu System

The Main Menu:

File V¥iew Chanmel Trigzer Horizeontal Curszor Measure Display Acqguire Utility Help

1. File: Load or save CSV, waveform and setup

IBUEN View Chanmel Trigger
_:'_} Load CSV Ctrl+0

Load Setups

Save C5V Ctrl+s
Save Image

Save Jetups

B Save Waveform

o Frint Ctrl+P

Frint Frewiew

Exit Ctrl+d

2. View: Change the user interface

P chamel Trigesr
Toolbar

[{ sidebar

Full Secreen

3. Channel: Set the vertical system

Eﬁl Trigger Ho

CH1 k
CHZ »
MATH r
Beference r

4. Trigger: Change trigger Mode, Sweep, Source, Slope and so on.

3
4
3

k

Cirl+T

HF BRejection

Hantek6102BE/Hantek6212BE User’s Manual 19



Chapter 2 Operation Basic

5. Horizontal: Sets time base parameters and format parameters.

Horizontal ERTSTIEN H
Time DIV L
Format r

Zera Ctrl+H

6. Cursor: Set cursor measure type

RGEAN Neasure

Source r

Type k

7. Measure: Set measurement parameters

M Display Acquire

Source L4
Vertical +
Horizontal r

Clear Measure

8. Display: Change wave display type and color.

IERS RS Acquire Utility
Type r
Grid Cirl+3
Intensity Cirl+I

Waweform Color

9. Acquire: Start, Stop, Autoset and other operation setting

Start Enter
l ace

Stop Sp

-~

y=.
Sampling L4
Aequisition 4
Buffer Size L4
Interpolation L

#H Auto Setup Ctrl+a

Temo Setting
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Chapter 2 Operation Basic

10. Utility: Utility setting

RFp FET F2
"?'-:E- Record F3
A Fass/Fail F4

Factory Setup

Langnage r

11. Help: Turn on help file

@ Contents F1
About. | F3
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Chapter 2 Operation Basic

2.3 The Horizontal System

Click “Horizontal” in main menu.

The following figure shows the horizontal parameters setting.

Horizontal MKW CE

Time/IIV »
Format r
Zera Cirl+H

1. Time/DIV: leads the setting of the time base parameters

2. Format: leads the setting of the horizontal format parameters

Of course, the user can also set the parameters in the right sidebar.

Harizontal
Time & DI

400u=z W

Format
¥aT w

Time i D%
4000z W

2.4 The Vertical System

Click “Channel” in main menu.

The following figure shows the vertical parameters setting.

E&I Trigzer Hom

CH1 r
CHZ L4
MATH ¥
Beference r

CHA1: Leads to the setting of the Ch1 parameters
CH2: Leads to the setting of the Ch2 parameters
Math: Leads to the setting of the Math parameters

L K K R 2

Reference: Leads to the setting of the Reference parameters

Hantek6102BE/Hantek6212BE User’s Manual
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Chapter 2 Operation Basic

You can also set parameters in the right sidebar.

Yertical
CH1
1.00% %

aC L
=10 bt

[w]cHz
A
a0 ~

%10 b

1. Select channel: [leHt [Jch2

2. VLTS/DIV: Set the selected channel voltage range.

4. BW Limit: Reject the frequency component higher than 20MHz.

2.5 The Trigger System

Click “Trigger” in main menu.
The following figure shows the trigger system control.

Horizontal  Cursar

Mode r
SWEED r
Source L4
Slope r
When P r
0% Chrl+T
HF Rejection

1. Mode: Sets the trigger mode to Edge trigger

2. Sweep: Selects the trigger sweep mode to AUTO, NORMAL or SINGLE
3. Source: Selects the trigger source to CH1, CH2, ALT, EXT., EXT./10.

4. Slope: Selects the edge trigger slope to Positive or Negative slope

Hantek6102BE/Hantek6212BE User’s Manual 23
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5. When PW: Selects the pulse width trigger condition
6. 50%: Sets the trigger level to the center of the waveform amplitude

7. HF Rejection: Eliminates trigger high-frequency (20M above)

The user can drag the trigger icon to adjust the trigger level and the trigger level will be
displayed on the top right corner.

2.6 Input Connectors

CH 1/CH 2: Input connectors for waveform display.
EXT.: Input connector for an external trigger source. Use the Trigger Menu to select the Ext.

source.

Other Connector:

GND.: Ground terminal
USB PORT: Connect the B-Type Plug of USB cable to this port.

CAL.: Probe compensation output.

Hantek6102BE/Hantek6212BE User’s Manual 24
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Chapter 3 Functions

€ Set Oscilloscope

€ Set Vertical System

€ Set Horizontal System
€ Set Trigger System

¢ Measure Signal

4 Utility Function

¢ The Display System
4 Save/lLoad

€ Print
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3.1 Setup the Oscilloscope

Use “AUOSET” to display a signal automatically.

Auto setup functions one time each time you push the “AUTOSET” button. The function
obtains a stable waveform display for you. It automatically adjusts the vertical scale, horizontal
scale and trigger settings. Auto setup also displays several automatic measurements in the

graticule area, depending on the signal type.

Connect a signal to the CH1 input:

1. Connect a signal to the oscilloscope as described above.

2. Click the “Acquire -> Autoset” button.

The oscilloscope will change the current settings to display this signal.

Save Setup

The oscilloscope software saves the current setup before you close the oscilloscope software.
The oscilloscope recalls this setup when you run the software next time. You can use the

“Save Setup” menu to permanently save setting.
Load Setup

The oscilloscope can recall the last setup before the oscilloscope software was running, any
saved setups, or the factory setup. You can use the “Load Setup” menu to permanently recall

setup.
Factory Setup

The oscilloscope software is set up for normal operation when it is shipped from the factory.

This is the factory setup. Push the “Factory Setup” menu to recall this setup.

Hantek6102BE/Hantek6212BE User’s Manual 26
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3.2 Set Vertical System

Click “Channel” in main menu.

Eﬁl Trigger Ho

CH1 k
CHZ ’
MaTH *
Reference r

3.2.1 Change CH1/CH2
Click “CH1/CH2”in “Channel” menu.

The CH1 Menu:

lrigger Horizental Cursor Measwre I

| ol Twrn Off
CHZ r Volt DTV r
MATH ¥ Conpling L
Reference r Frobe r
Filter k
Resat
Inwert

Bandfidth Limit

The CH2 Menu:

Irigger Horizontal Curszer Measure I

cH o N2 20w
| o Twn OFf
MATH r Volt/TTV ¥
Reference k Coupling L4
Probe r
Filter 4
Reset
Inwvert

Bandfidth Limit
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Chapter 3 Functions

The CH1/CH2 control panel in sidebar:

CH1
100w

:.&.C v:
.x1 by
[#]cHz

ooy
|AC w

w1 W

“erical

The Vertical function:

Turn ON/OFF: Turn on/off the channel

Volt/DIV: Select the channel voltage/div
Coupling: Select the channel coupling

Probe: Select the channel probe attenuation
Filter: Select software filter

Reset: Set the channel vertical position to zero
Invert: Turn on/off the invert function.

Bandwidth Limit: Limit the channel bandwidth to 20MHz to reduce noise.

Change Volt/DIV

You can click “Volt/Div” in “CH1/CH2” to select the voltage.

Turn Off

Yelt,/IIV

Coupling
Frobe

Filter

Reszet

Inwert

Gl

10. Om¥
Z0. Om¥
a0, Om¥
100mY
200mY
S00mY
1.00v
Z.00v
5.00¥

Hantek6102BE/Hantek6212BE User’s Manual

28



Chapter 3 Functions

You can also change “CH1/CH2” voltage in side bar.

Yertical
CH1
1.00%  w

10.0m%
20.0mY
20.0m*
100m
200ms
=00m

2.00%
=.00%

_><1 b

You cam left click and drag the mouse on the green knob or the yellow knob to change the
voltage.

Set Channel Coupling

Click “Coupling” in “Channel” menu.

Turn Off #H ﬁ
¥olt,/DIV k |

Coupling oc

Frobe r AC

Filter r GHD

FRezet

Inwvert

Eandfi1dth Limit

You can set the coupling to DC, AC or GND. If you set the coupling to DC, it blocks the AC
component of the input signal.

Probe Attenuation Setting

Select the attenuation factor for the probe. To check the probe attenuation setting, toggle the

probe menu to match the attenuation factor of the probe.

This setting remains in effect before you changed again.

Click “Probe” in Vertical Setup window to select the probe attenuation.
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Chapter 3 Functions

Al

T OeEr | O ™
Yolt/OIV L4
Coupling L4
Probe x 1
Filter L4 x 10

x 100
Reset

x 1000
Invert

Band#idth Limit

The probe setting window in the sidebar:

Caution: The attenuation factor changes the vertical scale of the oscilloscope so that the
measurement results refect the actual voltage levels at the probe tip.

Invert

The invert function turns the displayed waveform 180 degrees, with respect to the ground level.
When the oscilloscope is triggered on the inverted signal, the trigger is also inverted.
Turn on Invert:

Twrn Off

Yolt/OIV r
Coupling L4
Probe »
Filter »
Reset

Turn On

Band#idth Limit

Turn off Invert:

Turn Off

Volt/ DIV k
Coupling *
Frobe »
Filter *
Rezet

< Twert _>————Turn Off

Bandfidth Limit
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Chapter 3 Functions

The following picture shows the waveform before inversion:

Trig'D + 0.00uy

Time 400us

Trig'D + 0.00uY

gl 100V Time 400us

Set the Channel Bandwidth Limit

The oscilloscope is set to full bandwidth and will pass the high frequency component in the
signal if the “BW Limit” was turned off.

The oscilloscope will reject the frequency component higher than 20MHz if the “BW
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Limit” was turned on.

Turn Off

Yolt/IIV *
Coupling ¥
Frobe r
Filter *
Reset

Inwvert

| Fandfidth Limit

When the “BW Limit” was turned on, a “B” sign will be displayed at the bottom of display
screen.

CH1 SRR

Filter definition:
None: without the Filter, read out the actual value directly.

Lower: with low limitation filter, the waveform will look more thin than in “None” mode.

Higher: with high limitation Filter, the waveform will look more thin than in “Lower” mode.
3.2.2 Set Math

Click “MATH” in Channel menu to set MATH channel.
The MATH Menu:

4 Turn On/Off: Turn On/Off the MATH Channel.

4 Source A/B: Set the sources of the math channel.

4 Operate: Set operates type of the math channel.

4 Volt/DIV: Set the resolution of the math channel.

4 Probe: Set the math channel probe attenuation.

¢ Reset: Set the math channel vertical position to zero.
€ Invert: Turn on/off the invert function

The mathematic functions include addition, subtract, multiply and division for CH1 and CH2.

Source A/B:

Source A and Source B menu:

Turn Dff ' Turn DEf

Source h CH1 Soarce A r

Source B b CHz Source B CH1
Operate » Operate r CHz
Volt,/ DIV » Volt/IIV r

Frobe r Frobe L4

Eezat Reszet

Inwert Inwvert
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Operate:

Four Types:

A+B Add source A and source B
A-B Subtract source B from source A
AxB Source A Multiply source B

A/B Divided source A by source B

In this function, use the addition, subtraction, multiplication and division function to operate and
analyze the waveform.

Select the operate type in the Operate menu. Select source A and B. Then adjust the vertical
scale and offset to view the math channel clearly. The mathematic result can be measured by
the measure and the cursor.

The Math Function Display:

3.3.3 Set Reference

Click “Reference” in “Channel” menu to set REF channel.

Turn Off
Yolt/ DIV k

Rezet

Load Reference

Zave Reference
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The Reference Channel Function:

Turn On/Off: Turn on/off the reference channel.

Volt/DIV: Channel the resolution of the reference channel.

Reset: Reset the reference channel vertical position to zero.

Load Reference: Load the reference waveform from the “.ref” file from your computer.
Save Reference: Save the current reference waveform to your computer as “.ref’ format.
You can change the vertical scale of a waveform. The waveform display will contract or
expand relative to the reference level.

Click “Save Reference” to save the waveform to *.ref file. The saved source window appears.

Trig'D 4+ 0.00uy

Caution: If you turn on the “Reference” channel, the load file window will appear.
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3.3 Set Horizontal System

Click “Horizontal” in main menu.

Horizontal QRIS P
Time/DIV r
Format »

Zero Cirl+H

3.3.1 Change Time/Div

The “Time/Div”’ Menu:

Time/TTY &

Format r us r

LZero Ctrl+H ms r
3 b
min *
Hour r

LSS AN Curzor Measure Display Acquire

4. 00ns
10. Ons
Z0. 0ns
40. 0nS
100ns
Z00ns
400ns

Utili

Select the horizontal Time/Div (scale factor) for the main or the window time base.

The Horizontal Panel

Harizontal
Time § DI

400us w

Format
¥-T w

Click the blue knob can change Time/Div.

3.3.2 Change Format

Click “Format” menu.

LR ELG ARSI Curzor Measure Display

Time/IIY ary AU

Format Y- T

Tero  Cirl+H Roll
X- v
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In the “Format” item, set the waveform display format (Y-T, X-Y and Roll).

Y -T: Shows the relative relation between vertical voltage and horizontal time.

Roll: In Roll Mode, the waveform display updates from right to left.

X -Y: Show CH1 value at X axis; CH2 value at Y axis.

In Roll mode, the waveform display rolls from right to left. No trigger or horizontal offset control
of waveforms is available during Roll Mode, and it’s only available when set to 1s/div or slower.

Caution: If the time/div bigger than 1s, the format will change to Roll mode automatically.

3.3.3 Change Horizontal Position

The “Zero” menu:

Horizontal ERVETSTENPE
Time /OIY r

Format L

Zera Cirl+H

Click “Zero” to set the trigger point to the horizontal center of the screen.
Horizontal position changes the displayed waveform position, relative to the trigger point.

The user can drag on screen to change the horizontal position.

3.4 Set Trigger System

3.4.1 Set Trigger

Click “Trigger” in main menu.

Horizonkal  Cursor

Horizomtal Cw Mode r
3 Sweep r
3 Source »
» Slope r
r When Py L4
Ctrl+T 0% Chrl+T
HF BEejection HF Rejection

The trigger determines when the oscilloscope starts to acquire data and display a waveform.
When a trigger is set up properly, it can convert unstable displays or blank screens into

meaningful waveforms.

If the oscilloscope wants to acquire a waveform, it collects enough data so that it can draw the
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waveform to the left of the trigger point. The oscilloscope continues to acquire data while

waiting for the trigger condition to occur. The oscilloscope continues to acquire enough data so

that it can draw the waveform to the right of the trigger point after it detects a trigger.

The Edge trigger determines whether the oscilloscope finds the trigger point on the rising or

the falling edge of a signal. Select Edge trigger mode to trigger on Rising edge or Falling

edge.

The Pulse trigger occurs according to the width of a pulse. The signals can be detected

through

setting up the pulse width condition.

Mode: Select the trigger mode.

Mode Edge

Sweep:

Sweep ¥ Pulse
Source r

Slope »

When Py »

50% ChE+T

HF Rejection

Set the sweep mode to Auto, Normal or Single.

Made v12 2lple
Sweep Auko

Source » Morrmal

Slope 3 Single

When P r

50%: Chrl+T

HF Rejection

Auto: Acquire waveform even no trigger occurred

Normal: Acquire waveform when trigger occurred.

Single: Acquire waveform when trigger occurred then stop

Source:

You can use the trigger source options to select the signal that the oscilloscope uses

as a trigger. The source can be any signal connected to a channel BNC, or to the EXT. BNC.
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Mode F|/u b, ':/ ]
SwEED k

Source ZH1

Slope 3 CHZ

Whien Py » ALT

0% Chrl+T ExT

HF Rejection ExT/10

CH1: Select CH1 as trigger signal

CH2: Select CH2 as trigger signal

ALT: Select CH1 and CH2 as trigger signal

EXT.: Select EXT as trigger signal

EXT./10: Select attenuated EXT/10 as trigger signal

Slope: Set the slope to Rising (+) or Falling (-).

Mo de rp 2 E
Sweep L4

Source k

Slope +

S0% Ctrl+T -

HF BRejection

Rising: Trigger on rising edge

Falling: Trigger on falling edge

When PW: Set the pulse width trigger condition. (Hantek6212BE)

Mode *|/u _f).;;- ™
Sweep »
Source r
Slope k
When P + Less
50% Chel+T + Equal
HF Rejection + More
- Less
- Equal
- Moare

+ Less: Positive pulse width less than
+ Equal: Positive pulse width equal to
+ More: Positive pulse width more than
- Less: Negative pulse width less than
- Equal: Negative pulse width equal to
- More: Negative pulse width more than
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Note: There is only Edge trigger for Hantek6102BE.

50%: Sets the trigger level to the center of the waveform amplitude

The user can also change the trigger setting on trigger panel in sidebar.

Triciger
Trigger Mode Edge W
Trigger Sweep Auta W
Trigger Source CH1 hd

Trigger Slope + W

Pulse Width Setting
Trigger
Triggger Mode Pulze | w
Trigiger Sweep Ao hd
Trigger Source CH1 W
When Pulze Width |+ Less  w

Pulze Wickth 10.0n%

Click the pulse width value to set pulse width. The pulse width value range is 10ns - 10s. When
the condition is set, it will trigger and acquire the signals.

Pulse Width Setting

Setting

PuseWidth | 10 % ns  w

3.4.2 HF Rejection

Click “HF Rejection” in “Trigger” menu:

Mode r
Sweep r
Souree k
Slope r
S0% Ctrl+T

HF Bejection
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The user can turn on “HF Rejection” to eliminate trigger higher-frequency (20M above).

3.5 Save/Load

Click “File” in main menu to save waveform, setups and screen.

IEREN View Chanmel Trigger
;ﬁ Laad CSV Ctrl+0

Load Setups

Sawve CSV Ctrl+s
Save Image

Save Setups
E] Sawve Waveform

A Frint Ctrl1+F

Frint Frewview

Exit Ctrl+i

Save:
1. Save CSV

Save waveform data as a CSV file

2. Save Image
Save the software display window as a .bmp or .jpg file

3. Save Setups
Save the current oscilloscope setups to file

4. Save Waveform
Save waveform data as a TEST, WORD or EXCEL file.

Load:
1. Load CSV

Load the waveform that had saved as a CSV file

2. Load Setups
Load the instrument that had saved
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3.6 Utility Function

Click the “Menu -> Utility” to get into the “Utility” menu.

RFp FFT F2

% Record F3

A Fass/Fail F4
Calibration

Factory Setup

Langnage r

The “Utility” Functions:

*

*

FFT

Record

Pass/Fail

Calibration(See Self Calibration)

Factory Setup

Language
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3.6.1 Fast Fourier Transform Function

You can use the FFT mode to convert a time-domain signal into its frequency components
(spectrum). You can use the FFT mode for the following types of analysis:

To use the FFT mode, you need to click “Menu->Utility->FFT” to open the FFT setup window.

IFgy FFT F2
% Record F3
My Fass/Fail F4

The FFT setup window:

FFT Setting
Source [ v | Window | Rectanole | MO.of FreqBins 256  w | Scale |Linear W
Harmonics Infomation Measurement Information
1 St EEEEL EEEEE SNR LR
znd E+t 414 L4414 THD E++41]
3rd Ekkkd EEE 11 ENOE Ekkkk
4th E+t 414 L4414 SFDR E++41]
Sth E+t 414 L4414 SINAD E++41]
Bth EEEEL EEEEE TmaIPDWEr LR
Yertical | S00my  w | DY Horizontal | x1 b

You can select the Source channel, Window algorithm, FFT number, and FFT Zoom factor. It
displays only one FFT spectrum at a time.

Source W
Source: CH1

Selects the channel used as the FFT source

. Windosy L'
Window: Rectangle

Selects the FFT window type
The windows reduce spectral leakage in the FFT spectrum.

. MO .of Freg Bine  |256 »
No. of Freq Bins:

Selects the FFT number
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Scale |Linear W

Scale:

Selects the vertical scale units

. Yertical | S00mY | DIy
Vertical: '~ " m

Selects the vertical scale

. Horizontal | x1 b
Horizontal:

Selects the FFT zoom factor
Sets horizontal scale, If the information is more than the quantity displayed to the display
window, more information is displayed by using scroll bar.

You can click the “Start” button to start FFT math, also you can click this button to stop FFT
math.

Click “Save” button if you want to save FFT math result. You can save the data into Word file,
Excel file or Text file.

Harmonic information window shows the information of Harmonics.

Harmonics Infamstion

1st a0.0kHz 1.20%

2nod 100kHz Tormy
3rd 1:3a0kHzZ 28.8mY
4th 200kHz 235my
Sth 250kHz 305mY
fith J00kHZ a7 .0m

Measurement information window shows the information about measurement of FFT.

Meazurement Information

SMRE -0.144d8
THL: -3.391dB
ENOB -0.316hit=
SFDR 4 562cB
SIMAD -1 G7adB
TatalPawver 5.505cB8
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The FFT display Windows:

3.6.2 Record and Play Back

Click “Record” in “Utility” menu.

Frr FFT F2

ﬁu Record F3

M Fass/Fail F4
Calibration

Factory Setup

Language L4
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The Record window will display. The following picture shows the Record Interface.

Eecord And Play Back rs_(|

Fecord Setup Play Back Setup

Source w Time Irterwal 1 2 (ms)

Start F
End Frame | 1000 | % AL TrEme

End Frame 1000

Time Irterval 1 * [m=)
> Current Frame

4 4% 43

Record : [ |Repest

Start Load

This function can record input waveform form CH1 or CH2. The maximum record length is
1000 frames.

Record Setup window:

Record Setup

Source | CH{  ow

End Frame 1000 -

Time Interval 1 > (ms)

Record : 35

Start Save

Source  (CH1 oW

Source:

Select record source channel. (CH1 or CH2)

End F 1000 -
End Frame: ~ ' ¢ _ .4

Set the number of record times. The max frames are 1000.

. Titne Irterval * (m=z
Time Interval: v (M=)

Set the time interval of record waveform.

Record: Record : 38

Record counter, it shows the record frames.
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Start
“Start” button:

Start to record frames. After you start to record waveforms, this button changes to “Stop”

button. It stops recording waveforms.

5
“Save” button: i

Save the record setup to file.

Play back setup window

Play Back Setup
Time Interval 1 o (N3]
Start Frame 1 3
Endd Frame 100 =
Currert Fratme 1 g
[ IRepest
Time Irterval 1 1 (M=)

Time Interval:

Set the time interval of play back.

.
Start Frame: =tartFrame ! -

Set the start frame of play back.

End Frame 100 :

End Frame:

Set the end frame of play back.

Current Frame: Current Frame 1 :
Displays the current frame of play back. You can also change this number to watch the

waveform one by one.
Repeat: [Repest
If it was checked, the waveform will be played back repeatedly.

Pl
“Play” button: =

Click this button to start playing back waveform. It can stop playing back if you started
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playing back.

Load
“Load” button: =
Click this button to load a record setup.

Note: When it plays back waveform, the other channel will be turned off.

3.6.3 Pass/Fail

Click “Pass/Fail” in “Utility” menu.

FFp FFT F2

@l BRecord F3

(A Pass/Fail T4
Calibration

Factory Setup

Language L4

The Pass/Fail window appears:

Paz=z/Fail g|ﬁ|fz|

Control Setting haszk Setting

Source  |CH1 % Yertical = (Dl £32)
Output |F.&.IL v| Harizontal * (D £ 50

[ stop vhen Output [ Create ] [ Save ] [ Load ]

Infarmation Dizplay

Fail : 1] s
Pazs: 0 wets
Total 1] wets
Operation
Start

The Pass/Fail function monitors changes of signals and outputs pass or fail signals by
comparing the input signal with the pre-created mask.
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Control Setting
Control Setting

Source CH1 b

Crutpt Fall w

[ ] stop when Output
. =ource CH1 w
Source:

Select the Pass/Fail channel

Output: it gt FalL W

Select the Pass/Fail output condition

Stop When Output: []Stop #hen Cutput

If it was checked, the Pass/Fail will stop when output.

Mask Setting

Mask Setting
Yertical & - (DY 7 32)
Horizontal 10 = (DI £50)
| Create | [ Save ] [ Load ]
. Yertical & S (Dl §32
Vertical: v )

Set the vertical limit range

. Harizontsl 10 (D is0
Horizontal: ' =0 v ( )

Set the horizontal limit range

“Create” button:

Click this button to create Pass/Fail area according to the mask

“Save” button:

Click this button to save the setups to file.

“Load” button:
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Click this button to load the saved setups file.

Information Display

Information Cisplay

Fail : ] wis
Pazs . 1] wis
Total 0 wis

Fail: Displays the fail waveform number
Pass: Displays the pass waveform number
Total: Displays the | total Pass/Fail waveform number

Operation

Operation

Start Stop

Click “Start” button to start the Pass/Fail test.

Click “Stop” button to stop the Pass/Fail test.

The Pass/Fail function display:

NOTE: Pass/Fall function is unavailable in X-Y mode and Roll mode.
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3.6.4 Factory Setup

Click “Factory Setup” in “Utility” menu to load default setups.

Fer FFT F2

.. Record F3

My FPass/Fail F4
Calibration

| Factory Setup

Language L4

When you click the Factory Setup in Utility menu, the oscilloscope displays the CH1 and CH2
waveforms and removes all other waveforms.
The oscilloscope set up for normal operation when it is shipped from the factory and can be
recalled at anytime by user.

The Factory Setup function does not reset the following settings:
€ Language option
€ Date and time

3.6.5 Language

Click “Language” in “Utility” menu.

Record
Fass/Fail

F/C ¥

Calibration
Factory Setup

Language Default English
fE P
v English
DNents=ch

There are four languages in “Language” menu. The default language is English.
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3.7 Measure Signal

3.7.1 Cursor

Click “Cursor” in main menu.

oo [

Source »

Type r

This method allows you to take measurements by moving the cursors.

1. Source
| Source CH1
Type r CHz
MATH

The user can set the source to CH1, CH2, FFT and MATH. But the FFT source can only use
Trace type.
When you use cursors, be sure to set the Source to the waveform on the display that you want
to measure.

2. Type

Sewee P O [El R £
| Type Hone
I:S Crozs

Trace

Vertical

Horizontal

There are four types of cursors: Cross, Trace, Vertical and Horizontal.
1) Cross

The Cross cursors appear as cross lines on the display and measure the vertical and
horizontal parameters.
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The Cross cursor display window:

The Cross measure result displays on status bar
Freq = 12 653 FHz Time = 75 543 us Volt = 3.403 V¥

2) Trace

The Trace cursors appear as vertical lines on the display and measure the waveform
amplitude at the point the waveform crosses the cursor.
The Trace cursor display window:
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The Trace cursor measure result display on status bar
Volt = 1.BSE ¥

3) Vertical

The Vertical cursors appear as vertical lines on the display and measure the vertical
parameters.

The Vertical cursor display window:

The Vertical cursor measure result display on status bar:
Freq = 12 568 EH= Time = T9.566 uS

4) Horizontal

The Horizontal cursors appear as horizontal lines on the display and measure the horizontal
parameters.
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The Horizontal cursor display window:

The Horizontal cursor measure result display on status bar:

Yolt = 3.502 ¥

3.7.2 Measure Menu

Click “Measure” in main menu.

The oscilloscope provides 20 parametric auto measurements (12 voltage and 8 time

measurements).

M Display Acquire
Source »
Vertical r
Horizontal r

Clear Measure

1. Source
Source CH1
Vertical r CHz
Horizonmtal r MATH

Chear Mlassure RN
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The user can use the “Source” menu to select a measure source.

2. \Vertical

Yertical Mz 1 mum

Horizontal * Minimum

Clear Measure Fealt To Peak

Top
Baze

Middle

EMS
Amplitude

Mean

Cxcle Mean

Positiwve Overshoot

Hegatiwe Owershoot

Maximum: Voltage of the absolute maximum level, measured over the entire waveform
Minimum: Voltage of the absolute minimum level, measured over the entire waveform
Peak to Peak: Peak- to-peak=Max-Min, measured over the entire waveform

Top: Voltage of the statistical maximum level, Measured over the entire waveform
Base: Voltage of the statistical maximum level, measured over the entire waveform
Middle: Voltage of the 50%level from base to top

RMS:T he Root Mean Square voltage over the entire waveform

Amplitude: Amp=Base-Top, measured over the entire waveform

Mean: The arithmetic mean over the entire waveform

Cycle Mean: The arithmetic mean over the first cycle in the waveform

Preshoot: Positive Overshoot =(Max-Top)/Amp*100%, measured over the entire waveform

3. Horizontal

Horizontal | Feriod |
Clear Measure Frequency

Eize Time

Fall Time

+D0uty Cyele

=Duty Cyele

+Ful=e Width
-Pulse Width
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Period: Time to take for the signal cycle to complete in the waveform

Frequency: Reciprocal of the period of the first cycle in the waveform

Rise Time: Time taken from lower threshold to upper threshold

Fall Time: Time taken from upper threshold to lower threshold

+Duty Cycle: Positive Duty Cycle = (Positive Pulse Width)/Period x 100%,Measured of the
first cycle in the waveform

-Duty Cycle: Negative Duty Cycle = (Negative Pulse Width)/Period x 100%, Measuredof the
first cycle in the waveform

+Pulse Width: Measured of the first positive pulse in the waveform. The time between the
50% amplitude points

-Pulse Width: Measured of the first negative pulse in the waveform. The time between the

50% amplitude points

4. Clear Measure

Clear all measure items on display screen.

The Measure Display Window:

Trig'D £ 0.00u

R 10.0m Time 400us

Caution: The results of the automatic measurements will be displayed on the bottom of the
screen. Maximum 8 results could be displayed at the same time. When there is no room, the

next new measurement result will make the previous results moving left, out of screen.

Hantek6102BE/Hantek6212BE User’s Manual 56



Chapter 3 Functions

3.8 The Display System

3.8.1 Display Type
Click “Type” in “Display” menu.
The following figure shows the parameters setting.

IERSARA N Acquire Utility Help

Vectors Ctrl+V¥

=]
Grid Ctrl+G Tots Ctrl+D
Intensity Ctr1+I BN Time /DI

Waweform Color ﬂ W b fllj(

If the Vectors type mode is selected, the waveform will be displayed as following figure.

[

Trig'D § 0.00uy

- H1 AR Tirme 400us

If the Dots type mode is selected, the waveform will be displayed as following figure.
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Time

3.8.2 Display Grid

Click “Display” in main menu.

IERSARAN Acquire Utility

Type »
Grid CirltG
Intensity Cirl+I
Waveform Color
The grid shows:
Trig'D 4 EE 0.00uv
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Without the grid shows:

TrigD £ 0.00uv

CH1 R Time 400us

3.8.3 Intensity and Persistence

Click “Display->Intensity” In main menu
The following figure shows the intensity dialog. It shows the display parameters setting.

Intensity

Garid Intensity J

Wigvefarm Intensity J

[ ]Persistence

You can change the grid and waveform color intensity in this dialog.
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Trig'D + .

Time 401

If you check “Persistence” and set persistence time:

For example:

Perzistence S005 W
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3.8.4 Waveform Color

Click “Display->Waveform Color”’ in main menu.

The following figure shows the waveform color dialog. It shows the waveform color setting.

¥aveform Color

CH1 Wigvetarm Colar

CH2 Wavetarm Calar

MATH Wigveform Color _

REF Wavetorm Colar

If you click the color rectangle, the color dialog will be showed.

The waveform color was changed:

Trig'D

g .00 Titne  40.0us
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3.9 Zoom In/Out and Drag Waveforms

The software will stop updating waveform after the user clicked “Stop” button, The user can
change the waveform display by adjusting the scale and position. When you change the scale,
the waveform display will increase or decrease in size. When you change the position, the
waveform will move up, down, right, or left.

;z Start Enter
Stop Space

Iragz

,‘.‘J Zoom In
‘;:} Zoom Out

Sampling r
hequisition L4
Buffer Size ¥

Interpolation L4

#H Auto Setup Cirlta

Zoom In/Out
The user can click “Zoom In/Out” in Acquire menu, then left or right click the mouse button on

display screen to Zoom in/out the waveform. Also the user can change Time/Div in Horizontal

menu or in Horizontal panel to zoom in/out the waveform.

Time § DI
4000z

Drag
The user can modify the waveform position after clicked “Drag” in “Acquire” menu following

the following steps.
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3.10 Interpolation

At the time 40ns/div or faster, user can use the different interpolation mode to get waveforms of
different smoothness.

The Step Interpolation:

Trig'D e 0.00uy

[ERf - 1.00v EEE~ 1.00v Time 40.0ns

The Linear Interpolation:

Trig'D e 0.o0uy

"Bl 1 .00y [ oY Time 40.0ns
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The Sin(x)/x Interpolation:

Trig'D ] + 0.00uy

Time 40.0ns

Caution: The default interpolation mode is Sin(x)/x.
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3.11 Acquisition Modes

Acquisition

When you acquire a signal, the oscilloscope converts it into a digital form and displays a
waveform. The acquisition mode defines how the signal is digitized and the time base setting

affects the time span and level of detail in the acquisition.

There are two acquisition modes: Normal and Average.

: Hormal

Average: 125

Normal: In this acquisition mode, the oscilloscope samples the signal in evenly spaced
intervals to construct waveform.

Average: In this acquisition mode the oscilloscope acquires several waveforms, averages
them, and display the resulting waveform. You can use this mode to reduce random noise.

Sverage | 128 | (1 ~128)

I Ok, ] ’Cancel]

3.12 Print And Print Preview

Click “Print” in “File” menu to set the printer to print the current waveform.

BN Vi ew  Channel Trigger

) Load 3V Ctrl+0

Load Setups

Sawe C3V Ctrlts
Save Image
Save Setups

B Save Waveform

| Yy Print Ctrl+F

Frint Frewview

Exit Ctrl+d

1. Click “print” in “File” menu to set the current waveform.
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2. Click the “Print Preview” in “File” menu to get into the Preview windows.

Click the “Print Preview” in “File” menu to get into the Preview window.

In “Print Preview” window, use the “Zoom In” button and the “Zoom Out” button to change
the size of the waveform graph. Click the “Close” button to turn this window off and click the
“Print” button to print the report.

The Print report:

Test Report

Date =01-11-2012  Tme = 08757

CH1T: CH2:

Sampling Rate = 28054 TirredDI%'= 40D b
CHT %OLT D= 100 hput Coupling = AC
CHZ “OLT D= 100N hput Coupling = AC
Note :
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Chapter 4 Application Example

¢ Simple Measurement

€ Pass/Fail Test

€ Capturing a Single-Shot Signal
€ The Application of the X-Y

€ Taking Cursor Measurements
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4.1 Simple Measurement

To acquire and display a signal, please do the steps as follows:
1. Connect signal to CH1 by using probe

2. Click the button on toolbar or “Acquire” -> “Auto Setup” on menu.

To measure the frequency and “Vpp”, you can do these steps as follows:

1. Click the “Measure”-> “Horizontal”-> “Frequency” button, the frequency of the signal

display on the bottom of the waveform interface.

2. Click the “Measure”-> “Vertical”’-> “Peak-to-Peak” button, the “Vpp” of the signal will
also display on the bottom of the waveform interface.

3. To clear the measurement on the waveform interface, click the “Measure”-> “Clear

Measure” button.

+ 0.00uy

CH1:Frequ=1.00kHz CH1MVpp = 4.00%

Time 400us
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4.2 Pass/Fail Test

The Pass/Fail function monitors changes of signals and outputs pass or fail signals by

comparing the input signal with the pre-created mask.

Pas=s/Fail Q|E|@

Control Setting Mask Setting

Source b “ertical (DIY ¥ 327
Ot FalL w Horizartal (D% 50)

[ St wihen Output | create | [ Save ] [ Load ]

Infarmation Display

Fail : a iz
Pazs : ] Wwis
Taotal : u] Wwis
Cpetation
Start

Control Setting:

Control Zetting

Source CHA1 b

Cutput | FAIL v

Stop When Output

Source CH1 b
Source:

Select the Pass/Fail channel.

Cutput |F.-'3~IL v |

Output:

Select the Pass/Fail output condition.

Stop When Output:

Mask Setting
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haszk Setting

“ertical 1 S (DIv i3

Horizontal 1 o | o ism

[ Cresate l [ Save ] [ Load ]

. i 1 %
Vertical: &M )| (Div £32)
Set the vertical limit range.
Horizontal 1 = | (D Fsm

Horizontal:

Set the horizontal limit range.

“Create” button:

Click this button to create Pass/Fail area according to the mask.

“Save” button:

Click this button to save the setups to file.

“Load” button:

Click this button to load the saved setups file.

Information Display:

Infarmation Display

Fail 1 wis
Pass : 115 wis
Total : 116 wis

Fail: Displays the fail waveform number.
Pass: Displays the pass waveform number.
Total: Displays the total Pass/Fail waveform number.

Operation:
Operation

Start

Click “Start” button to start the Pass/Fail test.
Click “Stop” button to start the Pass/Fail test.
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Caution: Pass/Fail function unavailable in X-Y mode and Roll mode.

4.3 Capturing a Single-Shot Signal

To capture a single event, it needs to gather some pre-test knowledge of the signal in order to
set up the trigger level and slope correctly. For example, if the event is derived from 3.3V
COMS logic, a trigger level of 1.2 or higher Volts should work on a rising edge. Do these steps
as follows:

1. Set the probe and the channel attenuations to X 10.

2. Set up the trigger in the Trigger Menu, or in the Trigger Setting window.

(1) Adjust the Trigger Mode to Edge.

(2) Set the Trigger Sweep to Single.

(3) Set the Trigger Source to CH1.

(4) Set the Trigger Slope to “+” which means you select the rising edge.

(5) Adjust the Volts/Div and the time base in a proper range for the signal.

(6) Drag the trigger level sign on the waveform display screen to proper position. It ally higher
a little above the normal level.

(7) Click START button to start capturing. When the trigger conditions are met, data appears
on the display representing the data points that the oscilloscope obtained with one acquisition.
This function helps to capture the signal occurrence easily, such as the noise with large
amplitude; set the trigger level higher a little above the normal level and press and wait.

When noise occurs, the instrument will record the waveform before and after the trigger.
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4.4 The Application of the X-Y Operation

X-Y Plot acts to analyze correlation of data of two channels. Lissajous diagram is displayed in
the screen when you use X-Y Plot, which enables to compare frequencies, amplitudes and
phases of counterpart waveform against the reference waveform. This makes it possible to
compare and analyze frequency, amplitude and phase between input and output.

Do these steps as follows:

1. Set the probe attenuation to “x10”. Set the switch to “x10” on the probes.

2. Connect the CH1 probe to the input of the circuit, and connect the CH2 probe to the

output of the circuit.

3. Click T0 button.

4. Adjust the vertical scale and offset to display approximately the same amplitude signals
on each channel.

5. Select X-Y format at Horizontal window. The oscilloscope will displays a Lissajous pattern
representing the input and the output characteristics of the circuit.

6. Adjust the scale and offset of the horizontal and vertical to a desirable waveform display.
The following picture shows a typical example.

7. Apply the Ellipse Method to observe the phase difference between the two channels.

Signal in X-Y Format:

|

J

Instruction of the Ellipse Method:
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Signal must be
centered in X a=

— -

- I
~a— 0

Sin@ = A/B or C/D, where 6 = phase shift (in degrees) between the two signals.
From the formula above:

0 = tarcsine (A/B) or *arcsine (C/D)
8 must be in the range of (0~11/2) or (311/2~21) if the main axis of the ellipse is between | and

[l quadrant .If the main axis is at Il and IV quadrant, 6 must be in the range of (1/2~1) or
(TT~311/2).
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4.5 Taking Cursor Measurements

Use cursors to make time and amplitude measurements on a waveform quickly.

Measure the Frequency or Time of the Sine Waveform

Do these steps:

1. Click “Cursor”-> “Source”, select CH1 (select CH2 if you want measure CH2).
2. Click “Cursor”-> “Type”, select Vertical.

3. Push left mouse button, and the vertical lines appear.

4. Drag the mouse button to the point you want to measure.

5. Release the left mouse button, the frequency difference and time difference will be
shown at the status bar.

Measure the Frequency and Time:

Read the details showing in the status bar.

Freq = 12. 565 EHx Time = T9. 566 uS

Measure the Amplitude of the First Waveform Peak of the Waveform
Do these steps:

1. Click “Cursor”-> “Source” select CH1 (select CH2 if you want measure CH2).
2. Click “Cursor”-> “Type”, select Horizontal.

3. Push left mouse button, and the Horizontal lines appear.
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4. Drag the mouse button to the point you want to measure.

5. Release the left mouse button, the voltage difference will be shown at the status bar.

Measure the Amplitude:

Read the details showing in the status bar.

Volt = 3.502 V

Trace the Amplitude of a fixed position on X-axis in a Waveform

Do these steps:

1. Click “Cursor->Source”, select CH1 (select CH2 if you want trace CH2).
2. Click “Cursor->Type”, select Trace.

3. Click the cursor at the position that you want traced of the wave in the waveform
window.
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Trace the Amplitude:

Read the details showing in the status bar.

¥olt = 1.B856 ¥

Caution: Click “Cursor->Type” to select “Cross”, you can measure time and amplitude at one

time.
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Chapter 5 Appendix

€ Appendix A: Specifications

€ Appendix B: General Maintenance
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Appendix A: Specifications

Specifications Table:

Input
Real-time sampling:
Max. sample .
rate 250MSal/s using one channel(Hantek6102BE)
250MSal/s using one channel(Hantek6212BE)
Channels 2
_ 100 MHz analog bandwidth(Hantek6102BE)
Bandwidth .
200 MHz analog bandwidth(Hantek6212BE)
Vertical 8 bits/channel (Hantek6102BE)
Resolution 9 bits/channel (Hantek6212BE)
10mV ~5V/div @ x1 probe(1,2,5 sequence)
Hantek6102BE 100mV ~ 50V/div @ x10 probe
1V ~ 500V/div @ x100 probe
Gain range 10V ~ 5KV/div @ x1000 probe
10mV ~10V/div @ x1 probe(1,2,5 sequence)
100mV ~100V/div @ x10 probe
Hantek6212BE 1V ~ 1000V/div @ x100 probe
10V ~ 10KV/div @ x1000 probe
Range 8 divisions
Offset level +/-4 divisions
Coupling AC, DC,GND
Offset 0.02 div
increments
Impedance 1M ohm
DC accuracy +/-3%

Input protection

35Vpk (DC + peak AC < 10 kHz, without external attenuation)

Display Mode Y-T, X-Y and Roll
Timebase
. Hantek6102BE 4ns/div ~ 1h/div(1-2-4 sequence)
Timebase range . .
Hantek6212BE 2ns/div ~ 1h/div(1-2-4 sequence)
Hantek6102BE Real-time sampling: 4ns/div ~ 400ms/div.
o Roll mode: 1s/div ~ 1h/div
Acquisition - - - -
mode Hantek6212BE Equivalent sampling: 2ns/div ~ 4us/div
Real-time sampling: 10us/div ~ 400ms/div
Roll mode: 1s/div ~ 1h/div
Range 10 divisions
Buffer Size 10K ~ 1M
Trigger
Type Hantek6102BE Edge trigger
Hantek6212BE Edge trigger, Pulse Trigger
Mode Auto, Normal and Single
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Autoset Yes

Range 10 divisions
Trigger level +/-4 divisions
Settabillity 0.02 div increments
Math

Vp-p, Vmax, Vmin, Vrms, Vamp, Vtop, Vbase, positive overshoot,
negative overshoot, average,RMS, cycle RMS, period, frequency,

Measurements . ) . . L .
positive pulse width, negative pulse width, rise time, fall time,
positive duty cycle, negative duty cycle

Math Addition, Subtraction, Multiplication, Division

FFT Rectangular, Hanning, Hamming, Blackman Window

Physical

Interface uUSB2.0
No external power source required.

Power
Bus-powered from USB

Dimensions 190 x100 x 35(mm)
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Appendix B: General Maintenance

General Care
Do not store or leave the oscilloscope where the device will be exposed to direct sunlight for
long periods of time.

Caution
To avoid damages to the device or probes, do not expose them to sprays, liquids or solvents.

To avoid damages to the surface of the device or probes not use any abrasive or chemical

cleaning agents.

Cleaning
In order to keep the instrument clean ,you need to check often whether the channels are
dusty or not .Please clean the instrument surface and the channel connecting point as per

the following cautions(Make sure the device disconnect form all power sources):

1. Remove loose dust on the outside of the oscilloscope and probes with a lint-free cloth.

2. Use a soft cloth dampened with water to clean the device.
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